[OmniOS-discuss] CIFS Issues

Aaron Curry asc1111 at gmail.com
Wed May 13 16:08:46 UTC 2015


I ran into the same issue when setting up my home server. Access to CIFS
works by IP but not name. I ended up setting up a second IP address and
created a DNS entry with a different name for that IP. I have no idea why
it works but it does.

Aaron

On Wed, May 13, 2015 at 6:10 AM, Dominik Hassler <hasslerd at gmx.li> wrote:

> Did you try to end your FQDN with a trailing dot?
>
> like: 'DATA.HOME.example.net.' in your example?
>
>
> Gesendet: Mittwoch, 13. Mai 2015 um 13:40 Uhr
> Von: "Matthew McGee" <mcgee at sci-world.net>
> An: omnios-discuss at lists.omniti.com
> Betreff: [OmniOS-discuss] CIFS Issues
>
> I am attempting to migrate my CIFS shares from FreeNAS to OmniOS.
> I have attempted a number of different installs and for now I am working
> in a VM
> for speed of reboots and testing.
>
> I have Windows 2012 AD, and a number of Mac OSX & Windows 7 clients.
>
> Server name = DATA
> Domain HOME.example.net[http://HOME.example.net]
>  I install the system, configure the IP of
> 10.0.1.230/8[http://10.0.1.230/8], set and test route, create a base boot
> environmentand a CIFS boot environment. Reboot into the CIFS boot
> environment.
>  I have attempted going straight to Napp-it and I have tried manual
> initialization as follows:
>  verify /etc/hosts and /etc/nodename entries
> Verify AD DNS
> verify system is using AD DNS server only
> nslookup to verify forward & reverse entries are functional and resolve on
> the host
> pkg install kerberos-5# Tried with and without this setting
> sharectl set -p ddns_enable=true
> klcient -T ms_ad
> kinit Administrator
> klist & verify output
> svcadm enable -r smb/server
>
> smbadm join -u Administrator
> Successful join
> smbadm list shows my domain.
> Verified kerberos delegation is allowed on the AD side.
> vi /etc/nsswitch.conf and add "ad" to passwd & group lines
> Have also tried adding smb line to pam
>
>
> Both of the following produce valid output
> touch foo && chown myuser at HOME.example.net[myuser at HOME.example.net] && ls
> -l foo
> id myuser at HOME # Although this doesn't show all my groups
> create a zfs filesystem and corresponding share called documents
>
> root at data:/root# smbutil view //myuser at DATA
> Password:
> Share        Type       Comment
> -------------------------------
> c$           disk       Default Share
> documents    disk
> IPC$         IPC        Remote IPC
> vss$         disk       VSS
>
> 4 shares listed from 4 available
>
> When I attempt to access from a Windows 7 host, I see the following:
>
> \\DATA is not accessible. You might not have permission to use this
> network resource.
> Contact the administrator of this server to find out if you have access
> permissions.
> The account is not authorized to log in from this station.
>
>
> \\10.0.1.230 - Works, I can set permissions, read & write files
>
> Neither the netbios nor FQDN function, but it functions by IP.
>
> Samba on FreeNAS or Fedora works without issues, but I need working FC and
> comstar will do that for me.
> I cannot seem to get the CIFS piece working and it is the one thing
> preventing me from moving forward.
> Any assistance would be appreciated. I hate asking for help but I've been
> working on this every night for a month
> and I know there must be one little thing I am missing, maybe a
> GPO?_______________________________________________ OmniOS-discuss mailing
> list OmniOS-discuss at lists.omniti.com
> http://lists.omniti.com/mailman/listinfo/omnios-discuss[http://lists.omniti.com/mailman/listinfo/omnios-discuss]
> _______________________________________________
> OmniOS-discuss mailing list
> OmniOS-discuss at lists.omniti.com
> http://lists.omniti.com/mailman/listinfo/omnios-discuss
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.omniti.com/pipermail/omnios-discuss/attachments/20150513/cefc414c/attachment-0001.html>


More information about the OmniOS-discuss mailing list