[OmniOS-discuss] Proliant gen9

Nate Smith nsmith at careyweb.com
Tue May 26 19:05:09 UTC 2015


Sorry. I missed the P440ar the first time I read through the thread.

https://www.illumos.org/issues/5390
 
Details this issue. It doesn’t look like the patch to get this driver supported has been tested or upstreamed. (someone else will have to answer).

Have you tried switching to HBA mode as detailed below?

http://h20564.www2.hp.com/hpsc/doc/public/display?docId=c03909334
 
I know that HP lists it as supporting Solaris 11, but that doesn’t mean it’s OmniOS compatible
 
http://h20564.www2.hp.com/hpsc/swd/public/readIndex?sp4ts.oid=7274897&swLangOid=8&swEnvOid=4167
 
This thread may be of some help. It looks like, at least for now, you have some bleeding edge hardware with unknown omnios support.
 
https://forums.freenas.org/index.php?threads/hp-gen9-server-w-p840-hba-mode-no-drives-visible.28620/
 
You might have to get another compatible storage controller, or pay some support bucks to get it tested/integrated. 
 
The supported storage controllers for the HP Gen 9s are here.
 
http://www.hp.com/hpinfo/newsroom/press_kits/2014/ComputeEra/HP_SmartStorage_ProLiantGen9_DataSheet.pdf
 
The P441 and P840 might have better luck, but I’m not sure. Ideally, you can run with a storage controller listed in the HCL
 
http://illumos.org/hcl
 
Hope this helps.
 
-Nate
 
 
 
 
From: Josh Barton [mailto:Josh.Barton at usurf.usu.edu] 
Sent: Tuesday, May 26, 2015 1:11 PM
To: Nate Smith
Subject: RE: [OmniOS-discuss] Proliant gen9
 
All I can find for the Storage controller is: HP Smart Array P440ar Controller
 
Thanks for taking the time to look at this
 
Josh
 
From: Nate Smith [mailto:nsmith at careyweb.com] 
Sent: Friday, May 22, 2015 5:38 PM
To: omnios-discuss at lists.omniti.com; Josh Barton
Subject: RE: [OmniOS-discuss] Proliant gen9
 
What is the on board storage controller? That's probably the unsupported hardware.

-Nate

-----Original Message----- 
From: Josh Barton [Josh.Barton at usurf.usu.edu]
Received: Friday, 22 May 2015, 7:10PM
To: omnios-discuss at lists.omniti.com [omnios-discuss at lists.omniti.com]
Subject: [OmniOS-discuss] Proliant gen9
An update to  my previous message:
I am using only  Legacy BIOS boot mode now and skipping UEFI entirely. Using the changes to the grub menu found in the link below I was able to  get to the install screen using the r151014 image however I still get a no disk found error. The controller is : HP Smart Array P440ar Controller
 
I have been trying to install OmniOS on a HP Proliant Gen9 server (r151014) but it will only boot in Legacy boot mode. R151012 will boot but no disks are found when I try to install. Has anyone experienced these issues? R151012 worked with our Proliant Gen8, is this a driver issue or something else?
 
 
 
See:
http://h20564.www2.hp.com/hpsc/doc/public/display?docId=emr_na-c04633840
 
Thanks,
 
Josh Barton
Utah Stage University Research Foundation
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.omniti.com/pipermail/omnios-discuss/attachments/20150526/74f61f50/attachment.html>


More information about the OmniOS-discuss mailing list