[OmniOS-discuss] Installation Boot hangs after CPU/USB initialization - Intel Motherboard

Svavar Örn Eysteinsson svavar at pipar-tbwa.is
Fri Apr 1 10:18:41 UTC 2016


I installed OmniOS on another machine, with Intel cpu and SATA controllers in ACHI mode
from a USB Key. 100% success.

Moved the hard drive to the problematic machine and the same story continues.
It will boot up, but soon as the CPU initializing is done and USB controller is probed it will freeze and hang.

As the screenshot shows.

Pretty much the same if I boot the installation from USB/SATA CDROM...

https://dl.dropboxusercontent.com/u/16134/IMG_0918.JPG


So it seems that I'm stuck with running Solaris 11.3...

Svavar



> On 31. mar. 2016, at 11:16, Michael Rasmussen <mir at miras.org> wrote:
> 
> Try to disable usb in bios before installing.
> 
> On March 31, 2016 11:59:20 AM GMT+02:00, "Svavar Örn Eysteinsson" <svavar at pipar-tbwa.is> wrote:
> So, Solaris 11.3 boots up and installs fine but not OmniOS.
> I sure would like to use OmniOS on this machine, so I ask are there any other debuging
> options for me at the installation level ?
> 
> Could I try to install OmniOS on a HDD/SSD on other machine with ACHI and boot it up on the problematic machine?
> Or is that just a no-go from the start?
> 
> Thanks again people.
> 
> Svavar
> Reykjavik - Iceland
> 
> 
> 
>  On 14. mar. 2016, at 21:28, Christian Kivalo <ml+omnios-discuss at valo.at> wrote:
>  
>  
>  
>  On 2016-03-09 11:00, Svavar Örn Eysteinsson wrote:
>  Hi Dan.
>  Thanks for the reply.
>  I disabled all the C-states and it's the same story.
> 
> If I boot from the SATA CD-ROM installation it hangs on boot right after :
>  cpu7: Intel(r) Xeon(r) CPU E5520 @ 2.27Ghz
>  cpu6: Intel(r) Xeon(r) CPU E5520 @ 2.27Ghz
>  cpu7: initialization complete - online
>  cpu6: initialization complete - online
>  See here :
>  https://dl.dropboxusercontent.com/u/16134/omnios_intel_cstates_disabled_boot.JPG <https://dl.dropboxusercontent.com/u/16134/omnios_intel_cstates_disabled_boot.JPG>
>  If I boot from USB stick, with USB 2.0 enabled and or disabled the
>  last message is always releated to usb stuff
>  right after cpu6: initialization complete - online.
>  So my BIOS configuration right now is :
>  Intel QPI Frequency Select [Auto Max]
>  Intel Turbo Boots Technology [Enabled]
>  Enhanced Intel Speedstep Tech [Enabled]
>  Processor C3 [Disabled]
>  Processor C6 [Disabled]
>  Intel Hyper-Threading Tech [Disabled]
>  Core Multi-Processing [All]
>  Execute Disable Bit
> [Disabled]
>  Intel Virtualization Technology [Disasbled]
>  Intel VT for Directed I/O [Disabled]
>  and some more.
>  My Bios Configuration can been seen here :
>  https://dl.dropboxusercontent.com/u/16134/omnios_intel_bios1.JPG <https://dl.dropboxusercontent.com/u/16134/omnios_intel_bios1.JPG>
>  https://dl.dropboxusercontent.com/u/16134/omnios_intel_bios2.JPG <https://dl.dropboxusercontent.com/u/16134/omnios_intel_bios2.JPG>
>  https://dl.dropboxusercontent.com/u/16134/omnios_intel_bios3.JPG <https://dl.dropboxusercontent.com/u/16134/omnios_intel_bios3.JPG>
>  https://dl.dropboxusercontent.com/u/16134/omnios_intel_bios4.JPG <https://dl.dropboxusercontent.com/u/16134/omnios_intel_bios4.JPG>
>  Maybe something for you there was a thread here some months ago...
>  It starts here https://www.mail-archive.com/omnios-discuss%40lists.omniti.com/msg03194.html <https://www.mail-archive.com/omnios-discuss%40lists.omniti.com/msg03194.html>
>  
>  and some messages into the the thread X2APIC is mentioned
>  https://www.mail-archive.com/omnios-discuss%40lists.omniti.com/msg03200.html <https://www.mail-archive.com/omnios-discuss%40lists.omniti.com/msg03200.html>
>  
>  https://www.mail-archive.com/omnios-discuss%40lists.omniti.com/msg03201.html <https://www.mail-archive.com/omnios-discuss%40lists.omniti.com/msg03201.html>
>  
>  and a link a blogpost by jeff sipek
>  http://blahg.josefsipek.net/?p=488 <http://blahg.josefsipek.net/?p=488>
>  
>  
>  Best regards,
>  Svavar O
>  On 8. mar. 2016, at 15:13, Dan McDonald <danmcd at omniti.com> wrote:
>  On Mar 8, 2016, at 6:17 AM, Svavar Örn Eysteinsson <svavar at pipar-tbwa.is> wrote:
>  Should I disable other CPU ? Should a enable C2, C3 state in BIOS or is that not relevant?
>  Disable C-states, that's general illumos advice (regardless of distro).
>  Dan
> 
>  OmniOS-discuss mailing list
>  OmniOS-discuss at lists.omniti.com
>  http://lists.omniti.com/mailman/listinfo/omnios-discuss <http://lists.omniti.com/mailman/listinfo/omnios-discuss>
>  
>  -- 
>  Christian Kivalo
> 
>  OmniOS-discuss mailing list
>  OmniOS-discuss at lists.omniti.com
>  http://lists.omniti.com/mailman/listinfo/omnios-discuss <http://lists.omniti.com/mailman/listinfo/omnios-discuss>
> 
> 
> 
> OmniOS-discuss mailing list
> OmniOS-discuss at lists.omniti.com
> http://lists.omniti.com/mailman/listinfo/omnios-discuss <http://lists.omniti.com/mailman/listinfo/omnios-discuss>
> 
> -- 
> Sent from my Android phone with K-9 Mail. Please excuse my brevity. 
> ---- This mail was virus scanned and spam checked before delivery. This mail is also DKIM signed. See header dkim-signature. 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.omniti.com/pipermail/omnios-discuss/attachments/20160401/22f4cfc5/attachment.html>


More information about the OmniOS-discuss mailing list