[OmniOS-discuss] Package Versions

Davide Poletto davide.poletto at gmail.com
Tue Mar 21 15:26:59 UTC 2017


Generally (and I write as a noob) I use:

pkg update -nv (it's a dry run)

then you can decide to apply all of them with:

pkg update -v (verbose mode)

or select the package proposed update you want to apply.

More info here:

https://omnios.omniti.com/wiki.php/GeneralAdministration#PackageManagement



On Tue, Mar 21, 2017 at 4:11 PM, Software Information <
softwareinforjam at gmail.com> wrote:

> Hi All
> I am just being introduced to IllumOS and OmniOS. I am coming from FreeBSD
> so as I learn I try to think of the command equivalent to what I know in
> FreeBSD. I am currently studying how to manage packages and so far, one
> thing that is eluding me is how to know which packages need updating. In
> freebsd I would do pkg version -v to see the list. Something like below
> would be the result.
>
> opendkim-2.9.2_5                   <   needs updating (index has 2.10.3_6)
> openntpd-6.0p1_3,2                 <   needs updating (index has 6.0p1_4,2)
> p5-Bit-Vector-7.3                  <   needs updating (index has 7.4)
> p5-Carp-Clan-6.04                  <   needs updating (index has 6.06)
> p5-Date-Calc-6.3                   <   needs updating (index has 6.4)
> p5-Locale-gettext-1.05_3           <   needs updating (index has 1.06)
> pcre-8.37_4                        <   needs updating (index has 8.40)
>
> What command would I use in IllumOS? Thanks for any help and I have to
> say, I am impressed with the concepts I am seeing.
>
> Regards
>
> _______________________________________________
> OmniOS-discuss mailing list
> OmniOS-discuss at lists.omniti.com
> http://lists.omniti.com/mailman/listinfo/omnios-discuss
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.omniti.com/pipermail/omnios-discuss/attachments/20170321/4a523bd5/attachment.html>


More information about the OmniOS-discuss mailing list