[OmniOS-discuss] Ang: Re: [developer] ZFS cache device allocation and free seem strange on my OmniOS r151022 system.

Johan Kragsterman johan.kragsterman at capvert.se
Sun Sep 17 05:58:32 UTC 2017


-----Andy Fiddaman <omnios at citrus-it.net> skrev: -----
Till: illumos-developer <developer at lists.illumos.org>
Från: Andy Fiddaman <omnios at citrus-it.net>
Datum: 2017-09-17 00:32
Kopia: Andriy Gapon <avg at freebsd.org>
Ärende: Re: [developer] ZFS cache device allocation and free seem strange on my OmniOS r151022 system.

On Thu, 14 Sep 2017, Matthew Ahrens wrote:

; The following commit should address the symptom you're describing; is it in
; your version of omnios?
; commit 6de76ce2a90f54fecb0dba46dca08c99cef7aa08
; Author: Andriy Gapon <avg at FreeBSD.org>
; Date:   Mon Feb 27 14:48:16 2017 -0800
;     7867 ARC space accounting leak
;     Reviewed by: Matthew Ahrens <mahrens at delphix.com>
;     Reviewed by: Dan Kimmel <dan.kimmel at delphix.com>
;     Approved by: Dan McDonald <danmcd at omniti.com>

That commit was merged to illumos-omnios on the 7th of March, so is definitely
in OmniOS r151022.


So apparently, that commit doesn't solve the problem...? It's a bit worrying...I got the exact same problem. Haven't hit me with any consequences yet, though, but that server doesn't have a lot of load.

I remember when this first showed up, someone had substantial problems, and we were all recommended to remove any cache devices until the problem was solved. And now it seems the problem isn't solved...?
So what is the recommendation now...? Remove it again?

Is someone looking into this? Is it reopened as an issue again? Or is it marked as solved and closed?

Rgrds Johan

Archives: https://illumos.topicbox.com/groups/developer/discussions/T737ffd52f97590b7-M831caefa636559cd9b878164
Powered by Topicbox: https://topicbox.com

More information about the OmniOS-discuss mailing list